Testing sstableloader between Cassandra 2.1 DSE and community edition 2.1

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Testing sstableloader between Cassandra 2.1 DSE and community edition 2.1

Serega Sheypak
Hi,  I have 2 cassandra clusters.
cluster1 is datastax community 2.1
cluster2 is datastax DSE

I can run sstableloader from cluster1(Community) and stream data to cluster2 (DSE)
But I get exception while streaming from cluster2 (DSE) to cluster1 (Community)


The expection is:

Could not retrieve endpoint ranges: 

java.lang.NullPointerException

java.lang.RuntimeException: Could not retrieve endpoint ranges: 

at org.apache.cassandra.tools.BulkLoader$ExternalClient.init(BulkLoader.java:282)

at org.apache.cassandra.io.sstable.SSTableLoader.stream(SSTableLoader.java:149)

at org.apache.cassandra.tools.BulkLoader.main(BulkLoader.java:94)

Caused by: java.lang.NullPointerException

at org.apache.cassandra.serializers.BooleanSerializer.deserialize(BooleanSerializer.java:33)

at org.apache.cassandra.serializers.BooleanSerializer.deserialize(BooleanSerializer.java:24)

at org.apache.cassandra.db.marshal.AbstractType.compose(AbstractType.java:142)

at org.apache.cassandra.cql3.UntypedResultSet$Row.getBoolean(UntypedResultSet.java:102)

at org.apache.cassandra.config.CFMetaData.fromSchemaNoColumnsNoTriggers(CFMetaData.java:1701)

at org.apache.cassandra.config.CFMetaData.fromThriftCqlRow(CFMetaData.java:1059)

at org.apache.cassandra.tools.BulkLoader$ExternalClient.init(BulkLoader.java:274)


Reply | Threaded
Open this post in threaded view
|

Re: Testing sstableloader between Cassandra 2.1 DSE and community edition 2.1

Serega Sheypak
Sorry
cluster1 community version is: ii  cassandra               2.1.3                   distributed storage system for structured data
cluster2 DSE version is: ii  dse-libcassandra        4.6.2-1                 The DataStax Enterprise package includes a production-certifie

2015-04-01 14:53 GMT+02:00 Serega Sheypak <[hidden email]>:
Hi,  I have 2 cassandra clusters.
cluster1 is datastax community 2.1
cluster2 is datastax DSE

I can run sstableloader from cluster1(Community) and stream data to cluster2 (DSE)
But I get exception while streaming from cluster2 (DSE) to cluster1 (Community)


The expection is:

Could not retrieve endpoint ranges: 

java.lang.NullPointerException

java.lang.RuntimeException: Could not retrieve endpoint ranges: 

at org.apache.cassandra.tools.BulkLoader$ExternalClient.init(BulkLoader.java:282)

at org.apache.cassandra.io.sstable.SSTableLoader.stream(SSTableLoader.java:149)

at org.apache.cassandra.tools.BulkLoader.main(BulkLoader.java:94)

Caused by: java.lang.NullPointerException

at org.apache.cassandra.serializers.BooleanSerializer.deserialize(BooleanSerializer.java:33)

at org.apache.cassandra.serializers.BooleanSerializer.deserialize(BooleanSerializer.java:24)

at org.apache.cassandra.db.marshal.AbstractType.compose(AbstractType.java:142)

at org.apache.cassandra.cql3.UntypedResultSet$Row.getBoolean(UntypedResultSet.java:102)

at org.apache.cassandra.config.CFMetaData.fromSchemaNoColumnsNoTriggers(CFMetaData.java:1701)

at org.apache.cassandra.config.CFMetaData.fromThriftCqlRow(CFMetaData.java:1059)

at org.apache.cassandra.tools.BulkLoader$ExternalClient.init(BulkLoader.java:274)



Reply | Threaded
Open this post in threaded view
|

Re: Testing sstableloader between Cassandra 2.1 DSE and community edition 2.1

Michael Shuler
On 04/01/2015 08:10 AM, Serega Sheypak wrote:
> Sorry
> cluster1 community version is: ii  cassandra               2.1.3
>            distributed storage system for structured data
> cluster2 DSE version is: ii  dse-libcassandra        4.6.2-1
>      The DataStax Enterprise package includes a production-certifie

Mixing versions of Cassandra may not work out well and isn't
recommended. DSC 4.6 is Cassandra 2.0.X.

--
Michael
Reply | Threaded
Open this post in threaded view
|

Re: Testing sstableloader between Cassandra 2.1 DSE and community edition 2.1

Serega Sheypak
Got it.

2015-04-01 20:39 GMT+02:00 Michael Shuler <[hidden email]>:
On 04/01/2015 08:10 AM, Serega Sheypak wrote:
Sorry
cluster1 community version is: ii  cassandra               2.1.3
           distributed storage system for structured data
cluster2 DSE version is: ii  dse-libcassandra        4.6.2-1
     The DataStax Enterprise package includes a production-certifie

Mixing versions of Cassandra may not work out well and isn't recommended. DSC 4.6 is Cassandra 2.0.X.

--
Michael